Welcome Visitor, Please Login or Register Now Saturday, October 23, 2021 06:43 PM 
Forums Index>Mewsoft Products>Searchawy>Sending HTML Formatted Acceptance Letters
New Topic   New Reply
Search for:
Author Message
corey corey's personal page
Registered Member
Posts: 14 Display member's posts
Joined: 10-23-21 06:43 PM
Location: Cleveland, OH
Member Offline
View Member's Profile Visit member's website http://www.lcbusinessmagazine.com Send private message
 
Back to top
Sending HTML Formatted Acceptance Letters Edit Delete Reply with quote Quote
First Post Posted on: 08-13-10 12:32 AM next post first post
:shock: I'm going nuts over this HTML Problem.

My server sends HTML formated emails. I've done it using both sendmail and HTML, but I can not get NetEngine to do it reliably. Let me explain.

My approval letter, that is setup in the Submission Options screen will send in HTML format when it exists as this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html><head></head><body>Dear <!--FName-->,<br>Thank you for adding <!--Company-->>!</body></html>



But not this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html><head></head><body>Dear <!--FName-->,<br>Thank you for adding <!--Company--> to our site!</body></html>



I've literally tried hundreds of different approaches, but there is some magic element that makes the system not send the email, and I can't figure it out. I need the letter to say much more than this.

If anyone is using HTML based acceptance letters could you send me the source code you are using, maybe I'm missing mime or content-type?

Thanks,
Corey
mewsoft mewsoft's personal page
Administrator Team Member
Posts: 5381 Display member's posts
Joined: 10-23-21 06:43 PM
Location: knxoville, TN, USA
Member Offline
View Member's Profile Visit member's website Mewsoft Corporation Send private message ICQ Messenger: ICQ AIM Messenger: AIM YIM Messenger: Yahoo MSN Messenger: MSN
 
Back to top
Re: Sending HTML Formatted Acceptance Letters Edit Delete Reply with quote Quote
Reply #: 1 Posted on: 08-13-10 10:58 AM next post previous post


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html><head></head><body>Dear <!--FName-->,<br>Thank you for adding <!--Company-->>!</body></html>



you mean you should have extra > char <!--Company-->>

try to remove the line form the email:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">


Mewsoft Support
www.mewsoft.com

corey corey's personal page
Registered Member
Posts: 14 Display member's posts
Joined: 10-23-21 06:43 PM
Location: Cleveland, OH
Member Offline
View Member's Profile Visit member's website http://www.lcbusinessmagazine.com Send private message
 
Back to top
Re: Sending HTML Formatted Acceptance Letters Edit Delete Reply with quote Quote
Reply #: 2 Posted on: 08-13-10 09:15 PM next post previous post
The extra ">" must have been a typo in the forum only I didn't have it in my letter.

When I remove:


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">


nothing seems to send at all using SMTP.

Here is another example.

This doesn't work:

<html><head></head><body><p>Dear <!--FName-->,<br><br>Thank you for adding <!--Company--> to our Lorain County Business Directory!</p></body></html>



and this doesn't work:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html><head></head><body><p>Dear <!--FName-->,<br><br>Thank you for adding <!--Company--> to our Business Directory!</p></body></html>



But this does work:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html><head></head><body><p>Dear <!--FName-->,<br><br>Thank you for adding <!--Company-->!</p></body></html>



and if I remove the first line like this:

<html><head></head><body><p>Dear <!--FName-->,<br><br>Thank you for adding <!--Company-->!</p></body></html>



then it stops working on even a simple email like that.

It just not making any sense to me. I mean it does send HTML formated emails, I've gotten it to work on basic simple emails, so something is causing it to die. Maybe I need to escape some characters? OR...?

I'm going to try some HTML emails that do not use classes and see what happens, any help would be appreciated. What file actually prepares and sends the acceptance letter?

Thanks,
Corey
corey corey's personal page
Registered Member
Posts: 14 Display member's posts
Joined: 10-23-21 06:43 PM
Location: Cleveland, OH
Member Offline
View Member's Profile Visit member's website http://www.lcbusinessmagazine.com Send private message
 
Back to top
Re: Sending HTML Formatted Acceptance Letters Edit Delete Reply with quote Quote
Reply #: 3 Posted on: 08-14-10 03:59 AM next post previous post
Okay, this HTML problem is driving me crazy! :shock:

I now have the system sending a fairly decent email, but I can't get a completed email sent because any small change makes it stop working. I need to find the email function, can you please point this out to me so I can look at the code directly?

I'm having the problem when I manually approve a link and send an acceptance letter.

I can have a working html letter sent, then go into the Submission Options add bold tags to any part of the letter and it not work. Does that make any sense to you?

is the mime-type text/html or multipart? If I could find the email function I could figure this out.

Thanks,
Corey
Focusman01 Focusman01's personal page
Registered Member
Posts: 118 Display member's posts
Joined: 10-23-21 06:43 PM
Member Offline
View Member's Profile Send private message
 
Back to top
Re: Sending HTML Formatted Acceptance Letters Edit Delete Reply with quote Quote
Reply #: 4 Posted on: 08-14-10 06:22 AM next post previous post

Okay, this HTML problem is driving me crazy! :shock:

I now have the system sending a fairly decent email, but I can't get a completed email sent because any small change makes it stop working. I need to find the email function, can you please point this out to me so I can look at the code directly?

I'm having the problem when I manually approve a link and send an acceptance letter.

I can have a working html letter sent, then go into the Submission Options add bold tags to any part of the letter and it not work. Does that make any sense to you?

is the mime-type text/html or multipart? If I could find the email function I could figure this out.

Thanks,
Corey




Hello

This may help.

http://www.mewsoft.com/forum/viewtopic.php?t=482

I simply typed up letter using Dreamweaver as the html editor. Then copy and paste entire code including tables to where ever needed:

Example:

<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body bgcolor="#FFFFFF" text="#000000">
<table width="557" border="0" cellpadding="0" cellspacing="0">
<tr>
<td width="557" height="304" valign="top">
<p>Hello</p>
<p>Just a test</p>
<p>Welcome to <!--URL--></p>
<p> Just a test on e-mail html</p>
<p>Just a test on e-mail html</p>
<p>Just a test on e-mail html</p>
<p>Just a test on e-mail html</p>
<p>Just a test on e-mail html</p>
</td>
</tr>
</table>
</body>
</html>

or

Just copy and paste text within cell structure of the table structure:

Example:

<td width="557" height="304" valign="top">
<p>Hello</p>
<p>Just a test</p>
<p> Just a test on e-mail html</p>
<p> Just a test on e-mail html</p>
<p>Just a test on e-mail html</p>
<p>Just a test on e-mail html</p>
<p>Just a test on e-mail html</p>
<p>Welcome to <!--URL--></p>
</td>

The final step is to place your classes where ever you want to within formatted letter.

Also by doing it this way, you need not to check, Send letter as HTML, but I still do just to be on the safe side.

Hope this helped.
corey corey's personal page
Registered Member
Posts: 14 Display member's posts
Joined: 10-23-21 06:43 PM
Location: Cleveland, OH
Member Offline
View Member's Profile Visit member's website http://www.lcbusinessmagazine.com Send private message
 
Back to top
Re: Sending HTML Formatted Acceptance Letters Edit Delete Reply with quote Quote
Reply #: 5 Posted on: 08-14-10 08:24 AM next post previous post
I think you misunderstood my problem. I know how to write HTML that's not the problem. The problem is that for some reason my HTML formated acceptance letter doesn't get sent and I can't figure out the reason why.

For example this letter sends:

<html><head></head><body bgcolor="#FFFFFF">
<IMG SRC="http://www.lcbusinessmagazine.com/lorain_ohio/images/business_magazine.jpg"; ALT="Lorain County Business Magazine" ALIGN="right">
Dear Travis,
<p>Thank you for adding your organization to Lorain County Business Magazine's Online Directory. Your site has been added to our database and we recommend that you view your listing for accuracy. (<a href="http://www.lcbusinessmagazine.com">http://www.lcbusinessmagazine.com</a>; Click the <b>Other</b> Category.)</p>

<p>Please read the following information and save a copy of this email for your records. Our primary purpose at LCBM is to help promote Lorain County Business' to the world via our unique Internet Technologies. Below are some additional features that can help you do that:</p>

<p><b>1. Advertising Services!</b> Please check out our magazine and online advertising opportunities: http://www.ecorey.com/search_engine_promotion/search_engine_marketing_promotion_services.php, or call us today!</p>

<p><b>2. Add your logo to your site!</b> We offer both free and paid Logo options. Follow this link for more information: <a href="http://www.lcbusinessmagazine.com/cgi-bin/dir/ms.cgi?action=GetPage&Name=YourLogo.html&Lang=English">http://www.lcbusinessmagazine.com/cgi-bin/dir/ms.cgi?action=GetPage&Name=YourLogo.html&Lang=English</a></p>;

<p>3. Become a LCBM Member, and use our enhanced member services to promote your company online. More information is available here: http://www.lcbusinessmagazine.com/cgi-bin/dir/myaccount.cgi?action=Sign_Up&Lang=English</p>;

<p>Here is your site information.:<BR>
If any of the following information is incorrect please let us know! Also, if any of the following fields are blank please consider revising your listing as these all help you to better promote your company.<BR><BR>
ID: <b>1103291782</b><BR>
Category: <b>Other</b><BR>
Title: <b>Area 57 Indoor Skatepark</b><BR>
Description: Indoor Skatepark in Elyria<BR>
Keywords: skateboarding, skatepark<BR>
User_ID: corey@ecorey.com 'Used to manage your listings.<BR>
Password: 'Used to manage your listings.<BR>
Email: corey@ecorey.com<BR>
Contact Name: Corey Duncan<BR>
Company: Area57<BR>
Job_Title: Webmaster<BR>
Address: 4222 Fairless Drive<BR>
Lorain, OH 44052<BR>
Phone: <BR>
Fax: <BR>
</p>
<p>Thank you,<BR>
The LC Business Magazine Team<BR>
http://www.lcbusinessmagazine.com</p>;
</body></html>



But if I add

<b></b>

tags around "3. Become a LCBM Member" then it no longers gets sent. This means that somehow what the program is sending to the mail server isn't correct, but I can't for the life of me figure out how such a small change could cause this problem considering it works fine otherwise.

Is there a size limit? Maybe I'm reaching the limit?

Does this make sense?

If anyone can tell me where the function that sends these emails is located please tell me as I may find a solution there. I've tried everything I can think of to make this work without looking at the source code, but it just won't. And I'm stuck. Please help.

All input welcome, as I'm stuck stuck stuck stuck stuck, and my boss is mad, mad, mad, mad, mad.

Also keep in mind, I have several other programs running and haven't had this problem with them. So it there must be either a problem with how I setup the NetEngine, but that doesn't explain why bold tags make it fail, or a problem in NetEngine that I need to be aware of.

It seems most likely that the problem is related to when it parses in classes, but I've gone so far as to remove all class uses and still have it fail. Could it be finding things that is shouldn't? And mistaken them for Classes?

Oh please help! I need love! :? [/code]
corey corey's personal page
Registered Member
Posts: 14 Display member's posts
Joined: 10-23-21 06:43 PM
Location: Cleveland, OH
Member Offline
View Member's Profile Visit member's website http://www.lcbusinessmagazine.com Send private message
 
Back to top
Re: Sending HTML Formatted Acceptance Letters Edit Delete Reply with quote Quote
Reply #: 6 Posted on: 08-14-10 10:20 AM last post previous post
How do you spell idiot? ID:10-T Error Warning! (Sorry bad joke!) Anyway I found the maillib.pm file and from there turned on the NET::SMTP debug option! After that of course I realized everything was working, and that I was an idiot.

Basically once I realized that the email was sending correctly I checked the mail server receiving the email and discovered that after so many HTML characters Spam Assasion rated the email high enough to be spam.

For the record, if interested it appears that if additional mime information is sent with the email this is avoided.

Sorry for all the to-do about nothing.

Corey
Page 1 of 1
Go to page:

New Topic   New Reply Mark Unread
Jump to:  
Delete   Move     Lock   +Favorits   +Notify   Print