Welcome Visitor, Please Login or Register Now Saturday, August 08, 2020 09:23 AM 
Forums Index>Mewsoft Products>Searchawy>Still a problem with 'Sign Up' & 'Manage Account'
New Topic   New Reply
Search for:
Author Message
darcyv darcyv's personal page
Registered Member
Posts: 43 Display member's posts
Joined: 02-18-05 02:01 AM
Member Offline
View Member's Profile Send private message
 
Back to top
Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
First Post Posted on: 02-06-11 10:55 AM next post first post
I have had the same problem that a few people in this forum have had with a particular error message showing up with the 'Sign Up' & 'Manage Account' links:\ \ Can't locate POP3Client.pm in @INC (@INC contains: /home/babyever/public_html/cgi-bin/dir . /usr/lib/perl5/5.8.1/i686-linux /usr/lib/perl5/5.8.1 /usr/lib/perl5/site_perl/5.8.1/i686-linux /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at myaccount.cgi line 88.\ BEGIN failed--compilation aborted at myaccount.cgi line 88.\ \ As you suggested to the others I contacted my sys admin and had them install the perl module Mail::POP3Client .... However, they installed for me but I still get the error. They asked me to contact you for any suggestions.\ \ Thanks for your help.
mewsoft mewsoft's personal page
Administrator Team Member
Posts: 5381 Display member's posts
Joined: 08-08-20 09:23 AM
Location: knxoville, TN, USA
Member Offline
View Member's Profile Visit member's website Mewsoft Corporation Send private message ICQ Messenger: ICQ AIM Messenger: AIM YIM Messenger: Yahoo MSN Messenger: MSN
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 1 Posted on: 02-06-11 08:12 PM next post previous post

They may be installed it on a directory on your site only. ask them to install it with the rest of perl modules or in any perl path. just tell them to use cpan to install it, from the telnet they just type:

%cpan>install Mail::POP3Client

Also run the testserver.cgi from your site to see if perl can see it or not.


Mewsoft Support
www.mewsoft.com

darcyv darcyv's personal page
Registered Member
Posts: 43 Display member's posts
Joined: 02-18-05 02:01 AM
Member Offline
View Member's Profile Send private message
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 2 Posted on: 02-07-11 02:17 AM next post previous post
I passed along what you said to the sys admin and they said that is for sure the way they installed it. I ran the testserver.cgi and I can see two instances of it:\ \ 733- Mail::POP3Client 734- Mail::POP3Client
mewsoft mewsoft's personal page
Administrator Team Member
Posts: 5381 Display member's posts
Joined: 08-08-20 09:23 AM
Location: knxoville, TN, USA
Member Offline
View Member's Profile Visit member's website Mewsoft Corporation Send private message ICQ Messenger: ICQ AIM Messenger: AIM YIM Messenger: Yahoo MSN Messenger: MSN
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 3 Posted on: 02-07-11 05:22 AM next post previous post

What is the url to your testserver so we can check it.

Also they may be forced its installation without installing some other pre requests modules, they can try to uninstall it and reinstall. If they can not get it to work you will have to switch to another good hosting, check our partner.


Mewsoft Support
www.mewsoft.com

darcyv darcyv's personal page
Registered Member
Posts: 43 Display member's posts
Joined: 02-18-05 02:01 AM
Member Offline
View Member's Profile Send private message
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 4 Posted on: 02-08-11 01:38 AM next post previous post
I sent the url to your support@mewsoft.com address
darcyv darcyv's personal page
Registered Member
Posts: 43 Display member's posts
Joined: 02-18-05 02:01 AM
Member Offline
View Member's Profile Send private message
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 5 Posted on: 02-17-11 05:11 AM next post previous post
As per the prvevious message I sent my testserver url to your support@mewsoft.com address. In one of the previous posts you said: "Also they may be forced its installation without installing some other pre requests modules". What are the pre requests modules? Is this something they should know or is this something I need to tell them?\ \ Thanks again for all of your help.
wannauseit wannauseit's personal page
Registered Member
Posts: Display member's posts
Joined: 08-08-20 09:23 AM
Member Offline
View Member's Profile PM
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 6 Posted on: 02-17-11 05:24 AM next post previous post
I had a similar situation to this on a previous host. I needed a Perl module installed, they installed it. But there were "subs" of that module that they didn't install (almost as if they only installed part of it) and I was still getting an error for that module even though my server showed it was installed and testserver.cgi showed it was installed.
mewsoft mewsoft's personal page
Administrator Team Member
Posts: 5381 Display member's posts
Joined: 08-08-20 09:23 AM
Location: knxoville, TN, USA
Member Offline
View Member's Profile Visit member's website Mewsoft Corporation Send private message ICQ Messenger: ICQ AIM Messenger: AIM YIM Messenger: Yahoo MSN Messenger: MSN
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 7 Posted on: 02-17-11 12:51 PM next post previous post
Yes exactly as I said before they may be forced the installation, the "force" is an option when installing perl modules using CPAN or PPM which installs the module without installing all its pre requests or subs so when our test server search perl directory finds that modules but when you call it it shows the error due to perl can not load it for missing required other modules. I do not know why you are wasting all your time on them, just switch to another hosting if they do ot know how to install perl module.

Mewsoft Support
www.mewsoft.com

darcyv darcyv's personal page
Registered Member
Posts: 43 Display member's posts
Joined: 02-18-05 02:01 AM
Member Offline
View Member's Profile Send private message
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 8 Posted on: 02-18-11 09:30 AM next post previous post
Thanks wannauseit for your input. Mewsoft, I know you think I'm wasting my time with my hosting company but except for this issue they've been fantastic and I hate to just ditch them over this matter if it can possibly be resolved.\ \ I just forwarded them your's and wannauseit's responses. The sys admin's response was: \ \ ::I have just reinstalled the perl module you require, and the submodules and necessary modules all showed as 'Already Installed' by CPAN.:: \ \ I checked the site again and still the same error. I wrote them back and he said:\ \ :big grinid the forum post reply contain any details as to which required submodules were missing for the other user? I agree that its probably one that is missing, but without knowing which one we cant check it as the server is saying they are all there::\ \ Again, my apologies if you feel that I'm wasting my time.. or certainly yours... I know it must be very frustrating on your end at times so I am extremely appreciative of the help you continue to give everyone. I would just like to try and resolve this because I really would prefer not to change hosts if at all possible.
mewsoft mewsoft's personal page
Administrator Team Member
Posts: 5381 Display member's posts
Joined: 08-08-20 09:23 AM
Location: knxoville, TN, USA
Member Offline
View Member's Profile Visit member's website Mewsoft Corporation Send private message ICQ Messenger: ICQ AIM Messenger: AIM YIM Messenger: Yahoo MSN Messenger: MSN
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 9 Posted on: 02-18-11 09:00 PM next post previous post

I modified the scripts to use a local copy of the POP3Client module that is already installed with the program and updated your site and it is working now:

Thanks


Mewsoft Support
www.mewsoft.com

darcyv darcyv's personal page
Registered Member
Posts: 43 Display member's posts
Joined: 02-18-05 02:01 AM
Member Offline
View Member's Profile Send private message
 
Back to top
Re: Still a problem with 'Sign Up' & 'Manage Account' Edit Delete Reply with quote Quote
Reply #: 10 Posted on: 02-19-11 03:18 AM last post previous post
Thank you soooo much! Really do appreciate your help. If it's not too much trouble could I have you remove my link from the previous post. I'm not ready for people to be poking around yet. Thanks!
Page 1 of 1
Go to page:

New Topic   New Reply Mark Unread
Jump to:  
Delete   Move     Lock   +Favorits   +Notify   Print