Welcome Visitor, Please Login or Register Now Friday, July 28, 2017 04:52 PM 
Forums Index>Mewsoft>FAQ>FastCGI Check Scripts
New Topic   New Reply
Search for:
Author Message
mewsoft mewsoft's personal page
Administrator Team Member
Posts: 5380 Display member's posts
Joined: 07-28-17 04:51 PM
Location: knxoville, TN, USA
Member Offline
View Member's Profile Visit member's website Mewsoft Corporation Send private message ICQ Messenger: ICQ AIM Messenger: AIM YIM Messenger: Yahoo MSN Messenger: MSN
 
Back to top
FastCGI Check Scripts Edit Delete Reply with quote Quote
First Post Posted on: 10-18-13 06:00 AM last post first post


To run FastCGI scripts or software, your server must have the required modules installed which depends

on the type of the server, for apache, it has the apache module mod_fcgid and the Perl module FCGI

must be installed.


How to check if your server has FastCGI enabled?


1)-download our Fast CGI test scripts from here:

http://www.mewsoft.com/download/fcgitest.zip

2)-upload the folder fastcgi to your server docs folder normally public_html or httpdocs

/public_html/fcgitest

or

/httpdocs/fcgitest


this folder contains 2 files:

.htaccess

test.fcgi


2)-change permissions to 755 for this folder and for the 2 files above.

3)-call the script test.fcgi from your browser like this:

http://www.yourdomain.com/fcgitest/test.fcgi

our demo: http://www.mewsoftcom/fcgitest/test.fcgi

4)-If you have FastCGI enabled you will see output like this:


FastCGI Enabled. We're running under FastCGI.


This is coming from a FastCGI server.

This is connection number: 1

Refresh this page 5 times and I will restart this process.


If you get output says FastCGI Disabled or if you see the script source code in your browser or you

get error, it means your server does not have FastCGI modules installed.


If you refresh the test page, the counter will keep its state between calls up to 5 then will reload

the program, this shows you are running under FastFCGI, If the counter keeps always the number 1

it means the Perl modules only installed but the server libs not installed.


Mewsoft Support
www.mewsoft.com

File
Page 1 of 1
Go to page:

New Topic   New Reply Mark Unread
Jump to:  
Delete   Move     Lock   +Favorits   +Notify   Print